HUIT Service Status Dashboard

OpenScholar websites not responding
Incident Report for HUIT
Resolved
All sites are back up.
Posted Oct 26, 2016 - 16:00 EDT
Investigating
We have received reports that some sites are not responding. We are working on assessing the situation.
Posted Oct 26, 2016 - 15:50 EDT