HUIT Service Status Dashboard

Contact Center Interruption
Incident Report for HUIT
Resolved
The issue with Contact Center has been resolved
Posted Jan 12, 2017 - 20:05 EST
Investigating
There have been reports that Contact Center is currently interrupted affecting incoming phone calls to users of it. HUIT staff are investigating the issue.
Posted Jan 12, 2017 - 19:51 EST
This incident affected: Telecommunication Systems.