HUIT Service Status Dashboard

Centrex VoiceMail Phone Degradation
Incident Report for HUIT
Resolved
Unified Communications, working with vendor, restored Centrex voicemail service. Users can now dial into 5-8168 to access voicemail.
Posted Sep 13, 2016 - 16:22 EDT
Investigating
Users attempting to access Centrex voicemail service (dialing into 5-8168 voicemail) may be unable to do so at this time.
Posted Sep 13, 2016 - 14:49 EDT