HUIT Service Status Dashboard

OpenScholar websites not responding properly
Incident Report for HUIT
Resolved
Vendor completed process. More details to be included in Problem Review.
Posted Oct 27, 2016 - 14:41 EDT
Investigating
We have received reports that some sites are not responding properly and are assessing the situation.
Posted Oct 27, 2016 - 14:15 EDT