HUIT Service Status Dashboard

Desktop Outlook Clients Not Connecting
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted Apr 20, 2017 - 17:26 EDT
Monitoring
Due to an issue with Microsoft Exchange Online, users were disconnected from their desktop Outlook applications, on Mac and PC versions 2013 and 2016.

Restart the Outlook desktop app to restore connection to Harvard email.
Posted Apr 20, 2017 - 11:08 EDT