HUIT Service Status Dashboard

HarvardKey Claiming Degradation
Incident Report for HUIT
Resolved
Restarted 4-HarvardKey host servers to synchronize timing.
Posted Mar 13, 2017 - 14:11 EDT
Investigating
Reports of delays of 3-5 minutes propagating HarvardKey data.
Posted Mar 13, 2017 - 12:05 EDT