HUIT Service Status Dashboard

Suspected NSTAR power outage affecting campus
Incident Report for HUIT
Resolved
Eversource (NSTAR) fixed the power issue. HUIT Infrastructure confirms network services are restored for the majority of campus and is working to repair limited number of switches impacted by power outage, including: Gund Hall, Mass Hall, 90 Mt. Auburn, Mather House, and 9 Ware Street.
Posted Jan 09, 2017 - 17:15 EST
Investigating
HUIT Infrastructure reports power outage across campus, with impact to multiple buildings and schools.
Posted Jan 09, 2017 - 15:43 EST