HUIT Service Status Dashboard

Office 365 Login Page Links (mso.harvard.edu) Interruption
Incident Report for HUIT
Resolved
Office 365 login links are restored. You can now access SharePoint, O365 Outlook Web App, and OneDrive services via mso.harvard.edu.
Posted Oct 17, 2016 - 13:07 EDT
Identified
Users attempting to log in to SharePoint, O365 Outlook Web App, and OneDrive services via mso.harvard.edu may be unable to do so at this time. You may alternately access these services at: O365 OWA: outlook.com/harvard.edu, SharePoint: hu.sharepoint.com, and OneDrive: https://hu-my.sharepoint.com
Posted Oct 17, 2016 - 11:43 EDT
This incident affected: Email Services (Office 365 Email & Calendar) and Collaboration & Sharing Services (Microsoft OneDrive, Sharepoint).