HUIT Service Status Dashboard

Users are unable to log into applications via Harvard Key
Incident Report for HUIT
Resolved
HUIT IAM reverted to authentication to original state, service is restored.
Posted Jan 18, 2017 - 10:30 EST
Identified
Users attempting to log into applications requiring HarvardKey are unable to do so at this time. HUIT IAM team is investigating and reverting to original state.
Posted Jan 18, 2017 - 10:10 EST