HUIT Service Status Dashboard

Calls to HUIT Service Desk routing to voicemail
Incident Report for HUIT
Resolved
Phone service to HUIT Service Desk (617 495-7777) is restored.
Posted Mar 22, 2017 - 14:05 EDT
Investigating
Please be advised calls to HUIT Service Desk (617 495-7777) are currently being directed voicemail after the scheduled message is played. Callers may not be able to speak to a Service Desk representative at this time. HUIT is investigating.
Posted Mar 22, 2017 - 13:48 EDT
This incident affected: Telecommunication Systems and Other Services.