HUIT Service Status Dashboard

Office 365 Email: some messages may be delayed
Incident Report for HUIT
Resolved
HUIT resolved the issue causing a small percentage of Office 365 Email to be delayed due to false identification as spam. These messages are queued for delivery.
Posted Sep 13, 2016 - 14:52 EDT
Update
HUIT continues to investigate an issue causing a small percentage of Office 365 Email to be delayed due to false identification as spam. Updates as more information is available.
Posted Sep 13, 2016 - 12:35 EDT
Investigating
HUIT is currently investigating an issue causing some Office 365 Email to be delayed due to false identification as spam. We expect to resolve the issue shortly and will provide an update later this morning.
Posted Sep 13, 2016 - 09:36 EDT
This incident affected: Email Services (Office 365 Email & Calendar).