HUIT Service Status Dashboard

Openscholar - Some sites down
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted May 18, 2017 - 18:35 EDT
Investigating
We are currently working on a server upgrade and may experience some downtime
Posted May 18, 2017 - 18:27 EDT