HUIT Service Status Dashboard

OpenScholar Publications issue
Incident Report for HUIT
Resolved
The issue is now resolved. Thanks for your patience!
Posted Feb 21, 2017 - 18:29 EST
Identified
There is an issue with publications created in 2017 being listed as just "published" rather than listing "2017". We are working on fixing the problem and will release the fix as soon as we can. You can follow the community issue here: http://bit.ly/2kKLqf8
Posted Feb 15, 2017 - 14:41 EST