HUIT Service Status Dashboard

HarvardKey Service Degradation
Incident Report for HUIT
Resolved
HarvardKey has returned to normal operations.
Posted Jan 19, 2022 - 14:12 EST
Investigating
New HarvardKey claiming is degraded at the moment. If you receive an error, please try again later.
Posted Jan 19, 2022 - 13:29 EST
This incident affected: HarvardKey (HarvardKey Authentication).