HUIT Service Status Dashboard

Concur Performance is Degraded
Incident Report for HUIT
Resolved
Concur is back up.
Posted Sep 13, 2018 - 14:27 EDT
Update
We are continuing to investigate this issue.
Posted Sep 13, 2018 - 09:04 EDT
Investigating
Concur is reporting wide-spread system performance issues. Users may have issues logging in, or if already logged in, users are experiencing errors, slow processing or are logged out when performing administrative functions, attempting to create, view, save or approve
expense reports and users profiles. The incident is actively being investigated. We appreciate your patience while we work to resolve this issue.
Posted Sep 13, 2018 - 09:03 EDT
This incident affected: Financial Applications (Concur).