HUIT Service Status Dashboard

ServiceNow Performance Issues
Incident Report for HUIT
Resolved
ServiceNow performance is back to normal. The issue was caused by a data import job and is now resolved.
Posted Jun 19, 2018 - 13:39 EDT
Identified
Some users are experiencing ServiceNow performance issues. The ITSM team are working with ServiceNow to resolve this issue.
Posted Jun 19, 2018 - 13:30 EDT
This incident affected: Research Administration & Compliance Systems (Agreements-DUA).