HUIT Service Status Dashboard

Wired and Wireless Outage
Incident Report for HUIT
Resolved
Router automatically recovered. Wired and wireless service is restored to building locations, including HUIT's Service Desk at 1033 Mass Ave.
Posted 10 days ago. Aug 07, 2017 - 13:33 EDT
Investigating
HUIT is investigating reports of lost wireless and wired network connectivity on campus. Currently this outage is impacting the river region, including HUIT's Service Desk.
Posted 10 days ago. Aug 07, 2017 - 12:42 EDT
This incident affected: Network Services and Other Services.