HUIT Service Status Dashboard

MIDAS Interruption
Incident Report for HUIT
Resolved
MIDAS access has been restored.
Posted 2 months ago. Jun 16, 2017 - 19:12 EDT
Investigating
Access to the MIDAS application is currently interrupted
Posted 2 months ago. Jun 16, 2017 - 15:27 EDT
This incident affected: Identity & Access Management Services.