HUIT Service Status Dashboard

@fas.harvard.edu email interruptions
Incident Report for HUIT
Resolved
The mail server that processes @fas.harvard.edu emails was brought back to health and now emails are flowing as usual.
Posted Aug 16, 2017 - 15:14 EDT
Investigating
HUIT is investigating reports of emails to @fas.harvard.edu sending bounceback messages.
Posted Aug 16, 2017 - 14:02 EDT
This incident affected: Other Services.