HUIT Service Status Dashboard

Network Connection Issues
Incident Report for HUIT
Resolved
The Network connection service is restored.
Posted Sep 13, 2018 - 15:55 EDT
Monitoring
Network connection service is restored and HUIT is monitoring.
Users who are still experiencing connection issues are advised to reboot their devices.
Posted Sep 13, 2018 - 15:17 EDT
Investigating
Users are experiencing network connection issues, wired and wireless, in different locations across the campus. HUIT is investigating.
Posted Sep 13, 2018 - 14:40 EDT