HUIT Service Status Dashboard

Microsoft Teams Service Disruption
Incident Report for HUIT
Resolved
Microsoft has identified the root cause of these issues and implemented a fix. Services are restored as of approximately 1:03 PM.
Posted Jan 23, 2020 - 14:16 EST
Investigating
Users are currently experiencing issues with Microsoft Teams. Microsoft is aware of these issues and they are actively troubleshooting/working to remediate.
Posted Jan 23, 2020 - 13:12 EST
This incident affected: Collaboration & Sharing Services (Microsoft Teams).