HUIT Service Status Dashboard

Network outages - Radcliffe and Garden Street buildings
Incident Report for HUIT
Resolved
Harvard Facilities from Campus Services Facilities Maintenance organization repaired the power station and moved power back to street power as of July 10 at 6:00PM.
Posted 3 months ago. Jul 23, 2019 - 15:26 EDT
Monitoring
Network Services are restored, running on temporary power, to Radcliffe and Garden Street buildings following yesterday's power outages. HUIT teams continue to monitor, coordinating with FMO and EverSource to fully restore power.
Posted 4 months ago. Jul 06, 2019 - 12:41 EDT
Investigating
Due to power outages in a number of buildings in the Radcliffe and Garden Street area network services are unavailable for Harvard community in these areas. HUIT teams are coordinating with the Facilities and Maintenance Office (FMO) to restore power and bring network services back online.
Posted 4 months ago. Jul 05, 2019 - 17:49 EDT
This incident affected: Network Services.