HUIT Service Status Dashboard

Peoplesoft Performance Issues
Incident Report for HUIT
Resolved
Peoplesoft performance is back to normal.
Posted Mar 22, 2019 - 10:40 EDT
Investigating
Users reported performance issues with Peoplesoft being very slow. HUIT is investigating.
Posted Mar 22, 2019 - 09:28 EDT