HUIT Service Status Dashboard

DUO Phone Call Authentications Delayed
Incident Report for HUIT
Resolved
DUO reported that the issue regarding phone call authentications is fully resolved and all services are now fully functional.
Posted Nov 05, 2018 - 12:33 EST
Investigating
Users reported authentication delays and timeouts with using phone calls for Duo authentication. HUIT is investigating.
Posted Nov 05, 2018 - 11:07 EST
This incident affected: Duo (Duo Security Core Authentication Service, Duo Security Phone Call Delivery).