HUIT Service Status Dashboard

my.harvard Application is Degraded
Incident Report for HUIT
Resolved
my.harvard is back to normal, Student and Course search results are now appearing as expected.
Posted 3 months ago. Jul 12, 2019 - 16:18 EDT
Investigating
Users reported issues with my.harvard application. The application is up but some key functionalities such as Course Search and Student Search are not working.
Posted 3 months ago. Jul 12, 2019 - 16:07 EDT
This incident affected: Teaching & Learning Platforms (Enterprise Student Systems (ESS)).