HUIT Service Status Dashboard

PeopleSoft Experiencing Performance and Access Degradation
Incident Report for HUIT
Resolved
Webservers had unusually high CPU usage. They were bounced, restoring PeopleSoft performance.
Posted 4 months ago. Jun 13, 2017 - 10:30 EDT
Investigating
PeopleSoft is experiencing performance degradation.
- Users who are already logged into PeopleSoft are seeing extremely slow performance.
- Others who are not yet logged in may not be able to login.
Posted 4 months ago. Jun 13, 2017 - 10:03 EDT
This incident affected: HR Applications.