HUIT Service Status Dashboard

VPN Connectivity Issues
Incident Report for HUIT
Resolved
VPN Services were back to normal as of 10:08 this morning.
Posted Mar 18, 2020 - 10:57 EDT
Investigating
HUIT is investigating VPN connectivity issues that is affecting some users.
Posted Mar 18, 2020 - 10:19 EDT