HUIT Service Status Dashboard

my.harvard Application is Degraded
Incident Report for HUIT
Resolved
my.harvard is back to normal, Student and Course search results are now appearing as expected.
Posted 4 months ago. Jun 27, 2019 - 12:16 EDT
Investigating
We are currently experiencing issue with my.harvard. The application is up but some key functionalities such as Course Search and Student Search are not working. HUIT is investigating.
Posted 4 months ago. Jun 27, 2019 - 10:49 EDT
This incident affected: Teaching & Learning Platforms (Enterprise Student Systems (ESS)).