HUIT Service Status Dashboard

Harvard Key Login Issues
Incident Report for HUIT
Resolved
The Harvard Key login issue is resolved. At the time some users registered their HarvardKey accounts, the HarvardKey system was experiencing a technical issue and did not save passwords correctly. Those users are being emailed to ask them to reset their HarvardKey passwords.
Posted Jan 16, 2019 - 15:19 EST
Investigating
Users who claimed their Harvard Key on Saturday 3pm onward are unable to login using their Harvard Key
Posted Jan 16, 2019 - 11:47 EST