HUIT Service Status Dashboard

OpenScholar sites internal to Harvard are not loading
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted Jul 01, 2020 - 09:16 EDT
Update
We are continuing to investigate this issue.
Posted Jul 01, 2020 - 09:16 EDT
Investigating
The OpenScholar development team is investigating the issue.
Posted Jul 01, 2020 - 08:31 EDT
This incident affected: Harvard Web Publishing Platform.