HUIT Service Status Dashboard

Microsoft Office 365 Service Degradation
Incident Report for HUIT
Resolved
We've verified Microsoft 365 services including Teams, Exchange services, SharePoint Online, Outlook.com are restored following Microsoft (vendor) resolution notice.
Posted Mar 16, 2021 - 07:21 EDT
Update
We continue to investigate and monitor services impacted. Microsoft (vendor) continues to take action to mitigate remaining impact for all Microsoft 365 services (globally).
Posted Mar 15, 2021 - 20:36 EDT
Investigating
We are experiencing issues with MS Teams and other Office 365 services.
Microsoft reported an incident for authentication errors across multiple Microsoft services.
Posted Mar 15, 2021 - 16:35 EDT
This incident affected: Email Services (Office 365 Email & Calendar) and Collaboration & Sharing Services (Microsoft OneDrive, Microsoft Teams, Sharepoint).