HUIT Service Status Dashboard

Extension School Online Services is Degraded
Incident Report for HUIT
Resolved
Login to Extension School Online Services is restored. DCE IT Support were able to resolve the issue.
Posted Nov 08, 2018 - 11:45 EST
Investigating
Users are currently unable to login to the Extension School online services website. To monitor the status of this issue please refer to http://status.dce.harvard.edu/
Posted Nov 08, 2018 - 11:14 EST
This incident affected: Other Services.