HUIT Service Status Dashboard

Network connectivity issues in the Harvard Yard region of campus
Incident Report for HUIT
Resolved
Network connectivity is restored. We continue to work with partners to ensure all systems have returned to normal operations.
Posted Jul 14, 2021 - 11:01 EDT
Identified
The issue has been identified and a fix is being implemented. We are awaiting final confirmation of return to normal operations.
Posted Jul 14, 2021 - 10:11 EDT
Investigating
The Harvard Yard region of campus is experiencing network connectivity issues. HUIT is aware and investigating.
Posted Jul 14, 2021 - 09:17 EDT