HUIT Service Status Dashboard

HarvardKey authentication degraded
Incident Report for HUIT
Resolved
Access to all applications affected by the Grouper issues have been restored.
Posted 3 months ago. Jul 12, 2019 - 11:36 EDT
Investigating
HUIT is investigating Grouper issues that can impact user access to a broad set of applications.
Posted 3 months ago. Jul 12, 2019 - 09:05 EDT
This incident affected: HarvardKey & Duo (HarvardKey) and Identity & Access Management Services.