HUIT Service Status Dashboard

Smith Center 9th Floor Network Outage
Incident Report for HUIT
Resolved
The 9th floor in the Smith Center is back to normal. The network team registered each unknown device separately.
Posted Jun 22, 2018 - 12:09 EDT
Investigating
The 9th Floor in the Smith Center has no network connectivity. HUIT is investigating.
Posted Jun 22, 2018 - 09:38 EDT