HUIT Service Status Dashboard

Verizon circuit outage effecting remote offices
Incident Report for HUIT
Resolved
Verizon repaired Network interface device (NID) and service is fully restored.
Posted May 16, 2018 - 12:07 EDT
Investigating
Some off campus Harvard locations are experiencing outages due to inclement weather last night including Harvard Depository, Arnold Arboretum, RMF, and HRCA. HUIT is working with Verizon towards restoring services.
Posted May 16, 2018 - 10:51 EDT
This incident affected: Other Services.