HUIT Service Status Dashboard

Service Desk's Phone Issues
Incident Report for HUIT
Resolved
Service Desk's phone system is receiving calls again as expected.
Posted Sep 03, 2019 - 12:35 EDT
Investigating
Service Desk's phone system is currently experiencing issues which is impacting the ability to receive calls. The issue is being actively worked on with the vendor. There is no ETA at this time. Please use the IT Help Portal https://harvard.service-now.com/ithelp in the meantime.
We apologize for any inconvenience.
Posted Aug 29, 2019 - 11:52 EDT
This incident affected: Telecommunication Systems.