HUIT Service Status Dashboard

My.harvard.edu presenting certificate errors
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted Mar 16, 2020 - 08:44 EDT
Investigating
Currently, attempts to visit my.harvard.edu, portal.harvard.edu etc. are presenting certificate expiration errors. An incident is open with the proper internal team to have new certificates created and implemented.
Posted Mar 16, 2020 - 08:32 EDT
This incident affected: my.harvard - Enterprise Student Systems (ESS).