HUIT Service Status Dashboard

Harvard University wireless interruption
Incident Report for HUIT
Resolved
HUIT resolved a software bug issue and guest access to Harvard University wireless is restored. HUIT teams continue to work on addressing and resolving any remaining user experience issues.
Posted 4 months ago. Jun 12, 2017 - 13:17 EDT
Investigating
Guest users may be unable to access Harvard University wireless network. Harvard staff already registered to Harvard University or Harvard Secure wireless networks prior to June 10th may also experience some interruption when reconnecting. HUIT teams are investigating.
Posted 4 months ago. Jun 12, 2017 - 11:40 EDT
This incident affected: Network Services.