HUIT Service Status Dashboard

Concur and Egencia Services are Degraded
Incident Report for HUIT
Resolved
The issue was resolved as of 12:40pm. access to Concur and Egencia are back to normal.
Posted Jul 22, 2021 - 12:57 EDT
Investigating
Concur and Egencia are currently unavailable. The incident is actively being investigated.
Posted Jul 22, 2021 - 12:37 EDT
This incident affected: Financial Applications (Concur).