HUIT Service Status Dashboard

HUPD Phone Services are Degraded
Incident Report for HUIT
Resolved
HUPD emergency lines are operational and stable as of 9:35pm last night.
Posted Sep 17, 2019 - 07:21 EDT
Monitoring
HUPD Emergency services at the current time are up and working. We have most services up expect a few office phones. We continue to monitor and watch as changes occur on the HUPD Network.
Posted Sep 16, 2019 - 15:53 EDT
Investigating
The HUPD’s urgent line (5-1212) is temporarily down. If you need emergency services please call Cambridge Police at 617-349-3300. In Boston please call 911 from a landline or cell. More information to follow.
Posted Sep 16, 2019 - 10:39 EDT
This incident affected: Telecommunication Systems.