HUIT Service Status Dashboard

HarvardKey Claiming Interruption
Incident Report for HUIT
Resolved
HarvardKey Self Service, including claiming, has been restored.
Posted 2 months ago. Jun 16, 2017 - 19:12 EDT
Investigating
The ability to claim a HarvardKey is currently interrupted
Posted 2 months ago. Jun 16, 2017 - 17:21 EDT
This incident affected: Identity & Access Management Services.