HUIT Service Status Dashboard

Wireless Network: Service Restored
Incident Report for HUIT
Resolved
Wireless network connectivity across campus has been restored.
Posted Mar 15, 2024 - 15:02 EDT
Monitoring
Wireless network connectivity has been restored. We will continue to monitor wireless networks to ensure stability throughout the day.

If you experience any further issues, please contact the HUIT Service Desk at 617-495-7777
Posted Mar 15, 2024 - 12:37 EDT
Update
Wireless connectivity is out campus-wide. Wired connectivity continues to be unaffected.

We have engaged our vendor to identify the root cause and restore wireless networking access.
Posted Mar 15, 2024 - 11:53 EDT
Investigating
We are currently experiencing reports of sporadic, wireless connectivity issues across campus. HUIT is actively troubleshooting and taking action to restore service.

Wired networking is unaffected at this time.
Posted Mar 15, 2024 - 11:25 EDT
This incident affected: Network Services (Wireless Networking).