HUIT Service Status Dashboard

OpenScholar websites not responding
Incident Report for HUIT
Resolved
OpenScholar sites are now responding normally.
Posted Oct 27, 2016 - 15:10 EDT
Investigating
We have received reports that some sites are not responding again and are assessing the situation.
Posted Oct 27, 2016 - 15:00 EDT