HUIT Service Status Dashboard

Errors accessing MIDAS using Chrome web browser
Incident Report for HUIT
Resolved
We have identified the root cause of the issue being due to a change in how Chrome handles authentication requests. We are working on a fix for the issue and will release it once development and validation are complete. Our investigations have found minimal user impact so we are closing out this status alert. If you have issues accessing MIDAS via the Google Chrome browser please switch to a different browser until the fix is released.
Posted Mar 22, 2024 - 15:45 EDT
Monitoring
HUIT is continuing to monitor this issue. While impact appears to be limited, please continue to use alternative web browsers (Safari, Edge, or Firefox) if you are unable to access MIDAS.
Posted Mar 21, 2024 - 15:42 EDT
Investigating
HUIT is investigating reports of issues accessing MIDAS using the latest version of the Chrome browser (123.0.6312.59). Users encounter a 401 - unauthorized error from HarvardKey.

At this point the issue appears to be isolated to Chrome. Switching to another browser (Safari, Edge, or Firefox) will allow users to access MIDAS.
Posted Mar 21, 2024 - 12:27 EDT
This incident affected: Other Services.