HUIT Service Status Dashboard

Access to Canvas Interrupted
Incident Report for HUIT
Resolved
Access to Canvas restored.
Posted Feb 09, 2017 - 10:22 EST
Investigating
Users are unable to login to canvas at this time. Users are receiving a sign-in error page.
Posted Feb 09, 2017 - 10:04 EST