HUIT Service Status Dashboard

Some OpenScholar sites are down
Incident Report for HUIT
Resolved
OpenScholar sites are back and functional.
Posted 21 days ago. May 28, 2019 - 08:49 EDT
Investigating
Some (but not all) OpenScholar websites are down. Issues started at approximately 7:07 am. The OpenScholar team is investigating...
Posted 21 days ago. May 28, 2019 - 08:00 EDT
This incident affected: Harvard Web Publishing Platform.