HUIT Service Status Dashboard

HarvardPhone: One-way audio issue with internal calls
Incident Report for HUIT
Resolved
The HUIT team confirmed the issue has been resolved.
Posted Mar 15, 2023 - 14:14 EDT
Investigating
There is currently a one-way audio issue that is affecting internal calls made from VoIP desk set phones. HUIT is aware of the issue and working to resolve the problem.
Posted Mar 15, 2023 - 10:44 EDT
This incident affected: Telecommunication Systems.