HUIT Service Status Dashboard

Kiteworks (Secure File Transfer) is Unavailable
Incident Report for HUIT
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 17:43 EST
Update
HUIT Secure File Transfer Powered by Accellion Kitworks is back to normal and the issue is resolved as of 11:57AM.
Posted Nov 06, 2020 - 12:58 EST
Investigating
Users reported issues accessing the secure file transfer (Kiteworks) service. HUIT is investigating.
Posted Nov 06, 2020 - 11:31 EST
This incident affected: Collaboration & Sharing Services (Secure File Transfer).