Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 13, 2026 - 06:00 EDT
Scheduled
From Thursday, August 13, 2026, at 6:00 AM to Thursday, August 13, 2026, August 13 at 6:00 PM, there will be no normal electric power available to the following buildings:
Cabot House Cabot House - Barnard Hall Cabot House - Bertram Hall Cabot House - Briggs Hall Cabot House - Cabot Hall Cabot House - Eliot Hall Cabot House - Whitman Hall
Currier House Currier House - Bingham Hall Currier House - Daniels Hall Currier House - Faulty Dean's House Currier House - Gilbert Hall Currier House - Tuchman Hall
Hilles Library Hilles Library
Pforzheimer House Pforzheimer House - Comstock Hall Pforzheimer House - Faulty Dean's House Pforzheimer House - Faculty Row Pforzheimer House - Holmes Hall Pforzheimer House - Jordan North Pforzheimer House - Jordan South Pforzheimer House - Moors Hall Pforzheimer House - Wolbach Hall
The purpose of the scheduled electrical outage is to perform repairs on the main 13,800V electrical switchboard at Hilles Station 862, located at Hilles Library.
Posted Aug 12, 2026 - 11:42 EDT
This scheduled maintenance affected: Utilities (Electricity).